Part 7. Konfigurasi Telnet dan SSH Router Cisco

Part 7. Konfigurasi Telnet dan SSH Router Cisco

 

A. Materi Lab :

Melanjutkan bab konfigurasi Telnet dan SSH sebelumnya, kali ini, akan kita bahas mengenai konfigurasi Telnet dan SSH di router cisco device. Pembuatan konfgurasi secara garis besar adalah sama. Berikut ulasan materinya :

B. Topologi :

csv.png

C. Konfigurasi

Konfigurasi yang pertama adalah konfigurasi Telnet.
Buka CLI Sakti-R1. Setting IP Address dan netmask sesui topologi. Jangan lupa ubah hostname terlebih dahulu.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Sakti-R1
Sakti-R1(config)#interface fa0/1
Sakti-R1(config-if)#no shutdown
Sakti-R1(config-if)#ip address 192.168.2.1 255.255.255.0
Sakti-R1(config-if)#exit
Sakti-R1(config)#interface fa0/0
Sakti-R1(config-if)#no shutdown
Sakti-R1(config-if)#ip address 192.168.1.1 255.255.255.0
Sakti-R1(config-if)#exit
Sakti-R1(config)#

Jangan lupa setting pula IP di PC dan Laptop Client

Kita bisa tes menggunakan PING apakah Sakti-PC1 sudah terhubung dengan Sakti-Laptop1.Kita bisa tes menggunakan PING apakah Sakti-PC1 sudah terhubung dengan Sakti-Laptop1.

Packet Tracer PC Command Line 1.0
C:\>ping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data:
Reply from 192.168.1.2: bytes=32 time=12ms TTL=128
Reply from 192.168.1.2: bytes=32 time=19ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time=9ms TTL=128
Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 19ms, Average = 10ms
C:\>

 

Packet Tracer PC Command Line 1.0
C:\>ping 192.168.2.3
Pinging 192.168.2.3 with 32 bytes of data:
Reply from 192.168.2.3: bytes=32 time=25ms TTL=128
Reply from 192.168.2.3: bytes=32 time=11ms TTL=128
Reply from 192.168.2.3: bytes=32 time=1ms TTL=128
Reply from 192.168.2.3: bytes=32 time=2ms TTL=128
Ping statistics for 192.168.2.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 25ms, Average = 9ms
C:\>

Nah, jika sudah berhasil PING, kita akan coba konfgurasi Telnetnya :
Setting password privileged terenkripsi.

Sakti-R1(config)#enable secret smk

Setting password line vty 123. Aktifkan mode timeout, sehingga jika tidak ada aktifitas selama 5 minutes 0 second, router akan logout sendiri.

Sakti-R1(config)#line vty 0 2
Sakti-R1(config-line)#password 123
Sakti-R1(config-line)#exec-timeout 5 0
Sakti-R1(config-line)#login local 
Sakti-R1(config-line)#exit

Aktifkan enkripsi clear text passwords

Sakti-R1(config)#service password-encryption

Buat banner Warning menggunakan MOTD agar user yang tidak punya otentikasi dilarang login.

Sakti-R1(config)#banner motd #Selain Admin Dilarang Login!!#

Terakhir buat username dan passwordnya untuk kita gunakan login melalui PC client.

Sakti-R1(config)#username miss secret 123456

Kita bisa cek melalui client.

C:\>telnet 192.168.1.1

Trying 192.168.1.1 …Open

Selain Admin Dilarang Login!!

User Access Verification

Username: miss
Password:
Sakti-R1>enablePassword:
Sakti-R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Sakti-R1(config)#

Selanjutnya, kita akan mencoba konfigurasi SSH (Secure Shell) untuk remote router cisco. Masih dengan topologi yang sama dan konfigurasi IP beserta netmask yang sama.Langkah-langkah konfigurasi hampir sama dengan konfigurasi di Switch.
Berikut :
Setting domain router

Sakti-R1(config)#ip domain-name sakti.smk

Setting Username dan Password untuk login :

Sakti-R1(config)#username root password cisco

Setting line vty 0 4 dan setting Transport Input All

Sakti-R1(config)#line vty 0 4
Sakti-R1(config-line)#transport input all 
Sakti-R1(config-line)#login local 
Sakti-R1(config-line)#exit 
Sakti-R1(config)#crypto key generate rsa 
The name for the keys will be: Sakti-R1.sakti.smk
Choose the size of the key modulus in the range of 360 to 2048 for yourGeneral Purpose Keys. Choosing a key modulus greater than 512 may takea few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]
*Mar 1 0:3:41.491: %SSH-5-ENABLED: SSH 1.99 has been enabled

Sakti-R1(config)#

Kita bisa langsung test mengunakan Client.

C:\>ssh -l root 192.168.2.1

OpenPassword: → ( passwd username )

Selain Admin Dilarang Login!!

Sakti-R1>enablePassword: → ( passwd privileged )
Sakti-R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Sakti-R1(config)#

 

Sekian,,

Wassalamualaikum,,

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s